ERROR: 'Data Access Components Error 1601 ERROR_INSTALL_SERVICE_FAILURE'
Description

When installing your Sage software, the following message can appear:

'Data Access Components Error 1601 ERROR_INSTALL_SERVICE_FAILURE'.

Cause

This error occurs if there's an issue with the installation files.

Resolution

To resolve this, install the Microsoft Visual C++ 2015 redistribution package, then install your Sage software directly from the installation files.

Install the Microsoft Visual C++ 2015 redistribution package

You can download and install the 32-bit version of the package here: vc_redist.x86.exe


Install Sage 50 Accounts from the installation files

The steps below assume you have already tried to install Sage 50 Accounts from a download.

  1. Press the Windows key  and press R.
  2. Type %temp% and press OK.
  3. Double-click the Sage Accounts xx folder. Where xx is your software version. 
  4. To access the 64-bit files, double-click the x64 folder.
  5. Double-click the packages folder.
  6. v30 only - Double-click the Sage.Accounts.Data.Exchange.Adapter.Setup.msi and follow the wizard.
     NOTE: After you install the Sage.Accounts.Data.Exchange.Adapter.Setup.msi file, restart Windows at the prompt. 
  7. Double-click Sage50Accounts_DataAccess.msi and follow the wizard. 
    If you're installing the Sage Data Service on the computer or server where you store your data, only run the Sage50Accounts_DataAccess.msi file. There's no need to follow steps 8 to 13.
      TIP:  If prompted to install the Microsoft Visual C++ 2015 redistribution package, click OK. Download and install the 32-bit version of the package, vc_redist.x86.exe, then install the Data Access Components again. The download is in the Redist folder alongside the Packages folder. 
  8. Double-click Sage50Accounts_Client.msi and follow the wizard.
  9. Double-click Sage50Accounts_ReportPack.msi and follow the wizard.
  10. Double-click Sage50Accounts_ODBC_x64.msi 64-bit operating systems only and follow the wizard.
  11. Double-click Sage50Accounts_SageNetwork.msi and follow the wizard.
  12. Open EBankingCoreInstaller.msi and follow the wizard.
  13. Double-click TMailSetup.msi and follow the wizard.

 NOTE: Installing from the installation files doesn't remove the older version. If your companies don't show when you open the software, reconnect to your data.  

If the issue persists, uninstall and reinstall the software.


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